Dynamics Crm Connect 1.4.1 issue when syncing contacts

Hi everyone,
 
I installed Sitecore Dynamics Crm 1.4.1 module on my local instance of Sitecore 8.2 revision 170728 but I have got an issue in the mapping when I want to sync some default crm fields from the Crm to sitecore in order to run the batch "CRM Contacts to xDB Sync Pipeline Batch".
 
I followed the sitecore guide to set up the connector within my sitecore instance and followed the guide  to set up the module.
 
In the connectionString I have written the url of the Crm Online.
 
I have executed a "Test Connection" and it was fine. 
 
I added:
      1. a new "Entity Attribute Value Accessors" item called Birth Date with the field of the Crm
      2. a new "xDB Contact Facet Property Value Accessor" item called Birth Date. In this item I have the field name "Contact Facet Name" with the value: Personal and Property Name field            with value: Birthdate.
      3. in "CRM Contact to xDB Contact" item I added a new mapping: Birth Date with the field source accessor: Data Access/Value Accessor Sets/Providers/Dynamics CRM/CRM Contact                Attributes/Birth Date(point 1) and the field target accessor: Data Access/Value Accessor Sets/Providers/Sitecore/xDB Contact Properties/BirthDate(point 2).
 
When I run the "CRM Contacts to xDB Sync Pipeline Batch" I get the following log in the Messages field:
 
11/14/2019 2:45:04 PM INFO Condition added to read entities modified on or after 11/14/2019 2:44:26 PM. (pipeline step: Read CRM Contacts, entity: contact)
11/14/2019 2:45:04 PM INFO Entities were read from Dynamics CRM. (pipeline step: Read CRM Contacts, endpoint: Dynamics CRM Entity Endpoint, entity: contact)
11/14/2019 2:45:04 PM DEBUG The object exists in the repository, so status was changed. (pipeline: CRM Contact to xDB Contact Sync Pipeline, pipeline step: Resolve xDB Contact from Queue, entry: Sitecore.Analytics.Tracking.ContactContext, status: NotUpdated)
11/14/2019 2:45:04 PM DEBUG At least one value mapping failed. (pipeline: CRM Contact to xDB Contact Sync Pipeline, pipeline step: Apply Mapping, mappings that failed: 1, value mapping ids: 1a104896-f7cc-490b-8e94-8aba507e6ebd)
11/14/2019 2:45:04 PM ERROR Pipeline step processing will abort because mapping set failed. (pipeline: CRM Contact to xDB Contact Sync Pipeline, pipeline step: Apply Mapping, mappings that succeeded: 1, mappings that were not attempted: 19, mappings that failed: 1)
11/14/2019 2:45:04 PM DEBUG Pipeline processor finished processessing pipeline steps. (pipeline: CRM Contact to xDB Contact Sync Pipeline, completed pipeline steps: 3)
 
 
I did not set up anything in Data Exchange Framework as I followed this part of the guide to map crm fields.
 
Any suggestion ? 
 
Thanks
Claudio
  • It sounds to me like you used the same field twice or maybe the field mapping for xdb and dynamics was incorrect. The ID is right here: 1a104896-f7cc-490b-8e94-8aba507e6ebd, so maybe recheck this mapping to ensure everything is setup correctly?
  • In reply to Jaina Baumgartner:

    Thanks Jaina for your answer but I checked already that field and It is referred to the item mapping "Birth Date" whose template is "/sitecore/templates/Data Exchange/Framework/Data Access/Mapping/Value Mapping" and there are not references to other parts.

    What do you mean exactly with the field mapping for xdb and dynamics ?

    Thanks