• Not Answered

WFFM: sometimes a form takes its time to submit and a user clicks one or two more times, hence triggering multiple save actions.

Web Forms for Marketers: sometimes a form takes its time to submit and a user clicks one or two more times, hence triggering multiple save actions. How can we ensure that submit is faster so this does not occur? Is this likely something built into the form, the presentation details of the page hosting the form or the servers? (we have two)

This is a bad user experience and it clutters up our form reports with bogus attempts. We used to be able to delete these directly from sitecore, but no longer can.

I'm seeking ideas on what causes this and how to fix it. It does not happen every time, but enough that we would like to isolate and remove the issue.

We have two standard save actions. Both are emails. One is to an owner inhouse and one tells the user they were successful.

Thank you in advance,

Jennifer

2 Replies

  • We have the same issue and using Sitecore 8.2, Update 5. I would be interested in finding a solution. On a related note, when we drive higher volumes of traffic to a Sitecore form on our website and we get multiple form submissions at the same time, there is a discrepancy in the number of emails we receive through the "Send email message" save action and the number of form submissions captured in Sitecore form reports. The "Send email message" save action fires on every submission and sends the email, while the form does not capture all form submissions in Sitecore to be exported in form reports. We compared the email received from the save action and an exported form report and out of about 100 submissions, there is usually about 6-10 submissions missing in the form report.
  • there is a setting that prevents several submissions:
    <!--The setting is desired to prevent multiple submiths of the same form withhin the specified time interval (in seconds)
    The value "0" disables the multiple submits peventing mechanism --><setting name="WFM.LimitMultipleSubmits.IntervalInSeconds" value="30" patch:source="Sitecore.MvcForms.config"/>

    But the best way would be to disable the submit button or implement a loading indication that blocks the form until the verfications and save actions are done.