• Not Answered

SXA website redirects to sitecore not found page

Hi Folks

I am getting a strange issue with my SXA multi site environment.

Issue Description: I have set up multiple SXA websites in my sitecore instance. All the websites have their own host names configured in their settings. The site seems to work fine but sometimes when i try to access the website it redirects to not found page. This redirection issue happens quite rarely, but still i am not able to find the root cause of this issue.

Has it got something to do with SXA which is not able to resolve the URL of the website ?

I have got this warning in the website logs 

1560 10:26:23 WARN  Request is redirected to document not found page. Requested url: /, User: sitecore\Anonymous, Website: scheduler

Looks like it is trying to find a page in scheduler website rather then the actual website url which is configured in the hostname. and therefore it goes to not found page.

Would be great, if you guys can help me with this.

Thanks Everyone

Regards

Mohit Paul

3 Replies

  • Hi
    SXA generally used for multiple site , I had a problem with redirection with two different site's home page under content node , please have a look Tenant -> Site Grouping -> Site Name and the right side content is set properly with home item path , I have two site , first website tenant I didn't set anything but the second one I need to set the start path , also see the config file if anywhere configuration is mismatching or something ....

     

  • In reply to DEBAL SAHA:

    Hi Debal

    Thanks for your response.

    Well, the site grouping for all the sites is correct. Also this is not permanent,but happens sometimes.

    Looks like SXA is not able to resolve the url sometimes and it falls back to scheduler website.

    I got an article

    doc.sitecore.net/.../manage_multiple_sites_with_the_sxa_site_manager

    Think of implementing this one. Looks like this might resolve the issue.

    Regards
    Mohit Paul
  • In reply to Mohit Paul:

    Hi Mohit,

    Did you get any success on SXA redirect issue. I also have similar issue where my site is stuck with sitecore scheduler and it goes to 404 or sitecore layout not found issue.

    I did check Sitecore Site Manager and found there were few sites fall into conflict situation but that is just powershell script to show results.

    Thanks & Regards,
    Deepak