Sparkpost TLS upgrade problems?

Our EXM stopped working this morning about 9 a.m. central. Last time this occurred, July 2, Sparkpost has posted on their support page (https://status.sparkpost.com/) that they were rolling out their change to no longer accept TLS 1.0 connections. That day, they rolled back the change to give users more time to get their TLS updates in place. Today, Sparkpost re-rolled it out. We don't connect to SparkPost directly but rather through Sitecore's email service, so I didn't think there was anything required on our end. 

But am I missing something? Did anybody else have to apply anything? Sitecore support did tell me you can force TLS 1.2 by adding this to global.asax


     <script runat="server">
            protected void Init(Object sender, EventArgs e)
            {
                   System.Net.ServicePointManager.SecurityProtocol = System.Net.SecurityProtocolType.Tls12;

            }
     </script>

I tried that in our stage environment but it didn't help. And I don't see why I would need to apply that if the problem is between Sitecore and Sparkpost.