• Not Answered

ARM Template Failing on deploying ZIP

I am using the XP Single ARM Template for version 9.2 from https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates/tree/master/Sitecore%209.2.0/XPSingle

It is currently falling over when trying to install the ZIP packages (when I run the deployment powershell locally). The exception I am getting is:

AppGallery Deploy Failed: 'Microsoft.Web.Deployment.DeploymentDetailedException: Object of type 'package' and path 'D:\\\\local\\\\Temp\\\\a2bd7688-a8f4-4f99-bbcf-a55e946dce34.zip' cannot be created. Learn more at: go.microsoft.com/.../. ---> Microsoft.Web.Deployment.DeploymentException: The Zip package 'D:\\\\local\\\\Temp\\\\a2bd7688-a8f4-4f99-bbcf-a55e946dce34.zip' could
not be loaded.

I have tried looking at the http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_EXCEPTION_WHILE_CREATING_OBJECT link and it just says it might be a permissions issue. I have made sure the zips are unblocked. 

My ZIP parameters in the parameters.json are as follows:

"siMsDeployPackageUrl": {
"value": "https://www.dropbox.com/s/0yy021g4hq7f87x/Sitecore.IdentityServer.3.0.0-r00211.scwdp.zip?dl=1"
},
"singleMsDeployPackageUrl": {
"value": "https://www.dropbox.com/s/a3oqzqc8ozt3mni/Sitecore9.2.0rev.002893%28Cloud%29_single.scwdp.zip?dl=1"
},
"xcSingleMsDeployPackageUrl": {
"value": "https://www.dropbox.com/s/96o0eqljexoeitl/Sitecore9.2.0rev.002893%28Cloud%29_xp0xconnect.scwdp.zip?dl=1"
}

Have I managed to pick up the wrong zips or something? Or have I missconfigured something else? 

Any help greatly appreciated,

Sam

1 Reply