Azure AD federated-authentication not working with Site core 9.1 Initial release , but same code and configuration woking with sitecore 9.0 update 1

Hi ,

 

we have configured federated-authentication in SiteCore 9.1 initial release  by following the steps available at 

https://labs.tadigital.com/index.php/2018/02/16/integrating-federated-authentication-for-sitecore-9-with-azure-ad/ 

http://blog.nikkipunjabi.com/2018/03/sitecore-federated-authentication-part-3-sitecore-user-and-claims-identity.html 

 

Now in sitecore 9.1 Initial release when I click on 'Sign-in with Azure Active Directory" its redirecting to Microsoft login page and also validating the user successfully, but once redirecting to my sitecore page its not opening the dashboard  or not logging to site core site, its because the user is not creating in sitecore.

but same configuration I tried with Sitecore 9.0 update 1 and update 2 its working fine and sitecore user is created and its opening the sitecore Dashboard.

 

So I checked the OWIN logs its showing me below logs

24824 13:17:12 WARN Microsoft.Owin.Security.OpenIdConnect.OpenIdConnectAuthenticationMiddleware - The nonce cookie was not found.
24824 13:17:12 ERROR Microsoft.Owin.Security.OpenIdConnect.OpenIdConnectAuthenticationMiddleware - Exception occurred while processing message:
Exception: Microsoft.IdentityModel.Protocols.OpenIdConnect.OpenIdConnectProtocolInvalidNonceException
Message: IDX21323: RequireNonce is '[PII is hidden]'. OpenIdConnectProtocolValidationContext.Nonce was null, OpenIdConnectProtocol.ValidatedIdToken.Payload.Nonce was not null. The nonce cannot be validated. If you don't need to check the nonce, set OpenIdConnectProtocolValidator.RequireNonce to 'false'. Note if a 'nonce' is found it will be evaluated.
Source: Microsoft.IdentityModel.Protocols.OpenIdConnect
at Microsoft.IdentityModel.Protocols.OpenIdConnect.OpenIdConnectProtocolValidator.ValidateNonce(OpenIdConnectProtocolValidationContext validationContext)
at Microsoft.IdentityModel.Protocols.OpenIdConnect.OpenIdConnectProtocolValidator.ValidateAuthenticationResponse(OpenIdConnectProtocolValidationContext validationContext)
at Microsoft.Owin.Security.OpenIdConnect.OpenIdConnectAuthenticationHandler.<AuthenticateCoreAsync>d__1a.MoveNext()

 

Any help is much appreciated.