Cannot bind argument to parameter 'Name' because it is an empty string

I am trying to install Sitecore 9 and I am receiving the following error:

 

Install-SitecoreConfiguration : Cannot bind argument to parameter 'Name' because it is an empty string.
At line:30 char:1
+ Install-SitecoreConfiguration @solrParams
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:00
Invoke-ManageServiceTask : Cannot bind argument to parameter 'Name' because it is an empty string.
At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.1.0\Public\Install-SitecoreConfiguration.ps1:641 char:47
+ & $entry.Task.Command @paramSet | Out-Default
+ ~~~~~~~~~
+ CategoryInfo : InvalidData: (:) [Invoke-ManageServiceTask], ParentContainsErrorRecordException
+ FullyQualifiedErrorId : ParameterArgumentValidationErrorEmptyStringNotAllowed,Invoke-ManageServiceTask

I had another few errors prior which I resolved. This one I am scratching my head at. I traced it back to the Install-SitecoreConfiguration file where the $entry is however I cannot understand what I am looking for as this is fully new to me. I deleted the certificates etc previously as that was causing another error.

Any additional questions are welcomed that I am provide more information to, right now I am unsure what more could be useful.

  • Which version of Sitecore are you trying to install?

    If you want Sitecore 9.0, use Sitecore Installation Framework 1.2 instead of 2.1.0

    In PowerShell:
    Remove-Module -Name SitecoreInstallFramework
    Import-Module -Name SitecoreInstallFramework -RequiredVersion 1.2.1

     

    For fixing multiple Certificate issues:

    In Windows PowerShell you can list them with:

    Set-Location Cert:\LocalMachine\Root
    Get-ChildItem | Format-Table FriendlyName, Thumbprint -AutoSize

     

    And you can delete one with for Example, (fill in your id):
    #Get-ChildItem Cert:\LocalMachine\Root\301F9A11F82BF45DA853BE573811AFF4ACA3B7CE | Remove-Item

  • In reply to Jan Bluemink:

    Thanks for this, it helped one error. I had tried that before but must have done something wrong. 

    I am now getting this error:

     

    [---------------------------------------- CreateSignedCert : NewSignedCertificate ------------------------------------]
    VERBOSE: Resolving ConfigFunction extension 'GetCertificate'
    VERBOSE: Resolved 'Invoke-GetCertificateConfigFunction'
    VERBOSE: Invoke-GetCertificateConfigFunction
    VERBOSE: Id: DO_NOT_TRUST_SIF200Root
    VERBOSE: CertStorePath: cert:\LocalMachine\Root
    VERBOSE: Found Cert with thumbprint: 591EFBEAA0F6982A7763AD97EEB71BC94E76F94E
    VERBOSE: Performing the operation "New-SignedCertificate: New signed certificate for sc90.xconnect_client" on target
    "c:\certificates".
    VERBOSE: Searching certificates in cert:\LocalMachine\My for Name sc90.xconnect_client
    Install-SitecoreConfiguration : System.InvalidOperationException: Multiple certificates returned from
    cert:\LocalMachine\My for Name sc90.xconnect_client (2 found)
    At line:19 char:1
    + Install-SitecoreConfiguration @certParams -Verbose
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration
    
    [TIME] 00:00:01
    Transcript stopped, output file is C:\Windows\system32\xconnect-createcert.190708 (3).log
    System.InvalidOperationException: Multiple certificates returned from cert:\LocalMachine\My for Name
    sc90.xconnect_client (2 found)
    At C:\Program Files\WindowsPowerShell\Modules\SitecoreFundamentals\1.1.0\Private\CommonResourceHelper.psm1:85 char:2
    +     throw $errorRecordToThrow
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [], Exception
        + FullyQualifiedErrorId : MachineStateIncorrect

  • In reply to Naimh Thompson:

    Yep, I had the same, after removing old certificates it works, I update the answer. with how to delete in powershell,

    also you can manage the certificates with Microsoft Managment Console, on cmd run mmc and below File menu select Add/Remove Snap-in. Now under Available snap-ins, click Certificates, and then click Add.

    Also be sure there are no self-signed certificate in the Trusted Root Certification Authorities, it will break xConnect.
  • In reply to Jan Bluemink:

    I removed the thumbprints in PowerShell, and then I got the Name error for solrParams again! Nightmare :(
  • In reply to Jan Bluemink:

    I tried everything you have suggested and I am getting the 'Name' error again for solrParams.
  • In reply to Naimh Thompson:

    Are you sure you use the correct SIF version? and the correct .json files for your Sitecore version?, what is actually the exact version you want to install?

    One other thing you can try is rename the Name to name. In the sitecore-solr.json the CreateCores section. Apparently the 'name' definition needs to be lowercase to work with SIF 2.0 +

    See www.koenheye.be/.../


    Also be sure you have all needed prerequisite.
  • In reply to Jan Bluemink:

    I got the name error away, the code I took from the documentation was missing the $solrService param all along.
    Now I have an error 'Property Value Cannot be found for the object' @xconnectParams
  • In reply to Jan Bluemink:

    This is what I get now.

    Error: Could not deploy package.
    Error: Internal Error. The database platform service with type Microsoft.Data.Tools.Schema.Sql.Sql130DatabaseSchemaProvider is not valid. You must make sure the service is loaded, or you must provide the full type name of a valid database platform service.
    Error Code: ERROR_EXECUTING_METHODError: Internal Error. The database platform service with type Microsoft.Data.Tools.Schema.Sql.Sql130DatabaseSchemaProvider is not valid. You must make sure the service is loaded, or you must provide the full type name of a valid database platform service.
    Error count: 1.
    
    More Information: Could not deploy package.
    Internal Error. The database platform service with type Microsoft.Data.Tools.Schema.Sql.Sql130DatabaseSchemaProvider is not valid. You must make sure the service is loaded, or you must provide the full type name of a valid database platform service.
    Internal Error. The database platform service with type Microsoft.Data.Tools.Schema.Sql.Sql130DatabaseSchemaProvider is not valid. You must make sure the service is loaded, or you must provide the full type name of a valid database platform service.
      Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_EXECUTING_METHOD.
    Install-SitecoreConfiguration : Command C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe returned a non-zero
    exit code - (-1)
    At line:48 char:1
    + Install-SitecoreConfiguration @xconnectParams
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration
    
    [TIME] 00:00:11
    Transcript stopped, output file is C:\Windows\System32\xconnect-xp0.190709 (4).log
    Invoke-CommandTask : Command C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe returned a non-zero exit code -
    (-1)
    At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\1.2.1\Public\Tasks\Invoke-WebDeployTask.ps1:36
    char:2
    +     Invoke-CommandTask -Path $Path -Arguments $msdeployArgs -TaskName ...
    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Invoke-CommandTask

  • In reply to Naimh Thompson:

    Have you read/check the prerequisite?
    looks like you missing the "Microsoft SQL Server Data-Tier Application Framework"
    See sitecore.stackexchange.com/.../could-not-deploy-package-error-while-installing-sitecore-9-update-2-setup-on-r

    Sitecore 9 was the first version with the SIF installer, in newer version things are better, and for the not yet released Sitecore 9.2. there will be an setup.exe on top of SIF to make it easier to set up a local dev environment. For the 9.0.x version you need to strictly follow al steps else you get cryptic error messages.

    Prerequisite for Sitecore 9 are:

    Powershell 5.1
    www.microsoft.com/.../details.aspx
    To check you powershell version run `powershell $PSVersionTable.PSVersion`

    Microsoft .NET Framework 4.6.2
    (www.microsoft.com/.../details.aspx

    Microsoft Web Platform Installer 5.0

    Web Deploy 3.6 for Hosting Servers Supports
    (Could be setup with IIS -> "Actions" bar -> Get New Web Platform Components)

    URL Rewrite 2.1
    (Could be setup with IIS -> "Actions" bar -> Get New Web Platform Components)

    Microsoft SQL Server Data-Tier Application Framework (DAC Fx) version 17.1 Supports
    (Could be setup with IIS -> "Actions" bar -> Get New Web Platform Components)

    MS SQL 2016 min required

    SOLR with ssl

    But check the installation manual of your Sitecore version. An use the config files, script specific for your version. see https://dev.sitecore.net/Downloads/Sitecore_Experience_Platform.aspx

    For a local developer installation you need the On Premises, Packages for XP Single

  • In reply to Jan Bluemink:

    I did, it was installed already. I had to go through the registry editor and set it all up. The errors are now gone at last, so thanks for all your help. Now need to just wait on finding license.xml file from somewhere as that is the last hurdle.