Sitecore 9 Installation Fails with "Error: .NET SqlClient Data Provider Msg 12809"

Details: You must remove all users with password before setting the containment property to NONE.

A little help? Target is SQLEXPRESS2016 Update 1.

  • Hi Richard,

    upgrade SQL 2016 to SP1 Cumulative Update 5 (i.e. 13.0.4451.0).

    Then create a new prefix for your databases and services. If you have partially completed database installs, the installer will fail.
    Regards,

    Pat

  • In reply to Patrick Stysiak:

    I have same issue. Upgrade did not fix it. I changed prefix as well. Contained database authentication is set to TRUE.
  • In reply to Pawel Adam Urban:

    Same here, I am running SQL Express 2016 13.0.4001, with contained authentication set to TRUE as per the installation guide.
  • It's likely you have other databases on the instance that have users and were created before attempting to change the containment level.

    Run the following and then try again:

    Use master
    GO
    sp_configure 'show advanced options', 1
    GO
    RECONFIGURE WITH OVERRIDE
    GO
    sp_configure 'contained database authentication', 1
    GO
    RECONFIGURE WITH OVERRIDE
    GO
    sp_configure 'show advanced options', 0
    GO
    RECONFIGURE WITH OVERRIDE
    GO
  • In reply to Pawel Adam Urban:

    In my case I was the problem. Trying to install Sitecore 9 on windows 2012 r2 i had to be creative. So I modified a script and I made copy paste mistake. I was calling twice Install-SitecoreConfiguration cmdles with xconnectParams. Story short - I tried to redeploy twice the same site(same databases).
    Error message - You must remove all users with password before setting the containment property to NONE- make sense. I already had a user with password in database that query wanted to change the property containment type
  • In reply to Pawel Adam Urban:

    Hey Paul are you using docker for your script? Might be easier in the long run when you want to spin up an environment.
  • In reply to Kieran Marron:

    Hi Kieran - This did not work, i have to change the prefix and re-run the install script

    thanks,
    Suresh.
  • Hey Rick,

    I got past this by deleting the databases that were previously created by SIF before it failed with a different error.

    My issue was because I was setting up an XP0 instance, but the database server was a separate machine. SIF is assuming you installed SQL on the machine you're running SIF from. In my case, the machine running SIF had the DacFx stuff installed that's required from the documentation, but I also needed to install parts of the SQL Server Feature pack. Specifically SQLSysClrTypes (32 and 64 bit, which is called out in the docs) and PowerShellTools (32 and 64 bit, NOT called out in the docs)

    If you don't have these, or just have the 64 bit versions, SIF will at some point fail and you'll have a bunch of partially created databases for xconnect. When you run SIF again you'll get the error you described. Log into the DB server and delete them manually and you'll get past this.
  • In reply to Kerwin ma:

    - to what are you referring? Kieran's solution or the new prefixes or both?