Sitecore 9 Installation Fails on Step 14 of 14: "Error requesting"

Same issue here but it's closed and none of the responses worked for me and the thread is marked as answered:


-https://localhost:8983/solr/#/ works fine, and no errors are logged

-I'm using Solr v. 6.6.2

-IIS is v10

-I've tried removing and adding .NET v3.5, doesn't matter either way

-URL rewrite v2.1 is installed


Error in Powershell:

[------------------------------------------------------------------------- UpdateSolrSchema : SitecoreUrl ------------------------------------------------------------------------------]
Install-SitecoreConfiguration : Error requesting The remote server returned an error: (500) Internal Server Error.
At [path to install file]\install.ps1:68 char:1
+ Install-SitecoreConfiguration @sitecoreParams
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:03:11
Transcript stopped, output file is [output file path]
Invoke-SitecoreUrlTask : Error requesting The remote server returned an error: (500) Internal Server Error.
At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\1.2.0\Public\Install-SitecoreConfiguration.ps1:253 char:21
+ & $entry.Task.Command @paramSet | Out-Default
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Invoke-SitecoreUrlTask


When I go to that URL ( I get this:

Server Error in '/' Application.

Instance failure.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.InvalidOperationException: Instance failure.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 

[InvalidOperationException: Instance failure.]
   System.Data.SqlClient.TdsParser.Connect(ServerInfo serverInfo, SqlInternalConnectionTds connHandler, Boolean ignoreSniOpenTimeout, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, Boolean withFailover, Boolean isFirstTransparentAttempt, SqlAuthenticationMethod authType, Boolean disableTnir) +6908987
   System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, SecureString newSecurePassword, Boolean ignoreSniOpenTimeout, TimeoutTimer timeout, Boolean withFailover, Boolean isFirstTransparentAttempt, Boolean disableTnir) +251
   System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(ServerInfo serverInfo, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance, SqlConnectionString connectionOptions, SqlCredential credential, TimeoutTimer timeout) +639
   System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(TimeoutTimer timeout, SqlConnectionString connectionOptions, SqlCredential credential, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance) +517
   System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, SqlCredential credential, Object providerInfo, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance, SqlConnectionString userConnectionOptions, SessionData reconnectSessionData, DbConnectionPool pool, String accessToken, Boolean applyTransientFaultHandling) +855
   System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection, DbConnectionOptions userOptions) +452
   System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnectionPool pool, DbConnection owningObject, DbConnectionOptions options, DbConnectionPoolKey poolKey, DbConnectionOptions userOptions) +70
   System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject, DbConnectionOptions userOptions, DbConnectionInternal oldConnection) +927
   System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject, DbConnectionOptions userOptions, DbConnectionInternal oldConnection) +109
   System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection) +1550
   System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection) +117
   System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection) +258
   System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions) +314
   System.Data.SqlClient.SqlConnection.TryOpenInner(TaskCompletionSource`1 retry) +126
   System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource`1 retry) +255
   System.Data.SqlClient.SqlConnection.Open() +128
   Sitecore.Data.DataProviders.Sql.DataProviderCommand..ctor(IDbCommand command, DataProviderTransaction transaction, Boolean openConnection) +107
   Sitecore.Data.DataProviders.Sql.<>c__DisplayClass26_0.<CreateCommand>b__0() +48
   Sitecore.Data.DataProviders.NullRetryer.Execute(Func`1 action, Action recover) +286
   Sitecore.Data.DataProviders.Sql.<>c__DisplayClass29_0.<CreateReader>b__0() +30
   Sitecore.Data.DataProviders.NullRetryer.Execute(Func`1 action, Action recover) +286
   Sitecore.Data.DataProviders.Sql.SqlDataApi.CreateReader(String sql, Object[] parameters) +281
   Sitecore.Data.Properties.SqlPropertyStore.GetStringValueCore(String name) +459
   Sitecore.Data.Properties.SqlPropertyStore.GetStringValue(String name) +73
   Sitecore.ContentSearch.Maintenance.IndexDatabasePropertyStore.Get(String key) +136
   Sitecore.ContentSearch.SolrProvider.SolrIndexSummary.get_LastUpdatedTimestamp() +82
   Sitecore.ContentSearch.Maintenance.Strategies.BaseAsynchronousStrategy.LogStrategyInitialization(ISearchIndex index) +94
   Sitecore.ContentSearch.Maintenance.Strategies.BaseAsynchronousStrategy.Initialize(ISearchIndex searchIndex) +83
   Sitecore.ContentSearch.Maintenance.Strategies.IntervalAsynchronousStrategy.Initialize(ISearchIndex searchIndex) +18
   Sitecore.ContentSearch.TypeActionHelper.Call(Action`1 action, IEnumerable`1 instances) +194
   Sitecore.ContentSearch.SolrProvider.SolrSearchIndex.Initialize() +180
   Sitecore.ContentSearch.SolrProvider.SolrContentSearchManager.Initialize() +169
   Sitecore.ContentSearch.SolrProvider.SolrNetIntegration.DefaultSolrStartUp.Initialize() +834
   (Object , Object[] ) +71
   Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) +469
   Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain) +22
   Sitecore.Nexus.Web.HttpModule.Application_Start() +161
   Sitecore.Nexus.Web.HttpModule.Init(HttpApplication app) +764
   System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +570
   System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +169
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +372
   System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +329

[HttpException (0x80004005): Instance failure.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +525
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +118
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +708


  • The script is trying to index it during the installation process. If it has failed, make sure your Solr is running and Re-build indexes using the Control Panel > Indexing Manager.
  • The script is not script for rebuild indexes, this is script for "Populate Solr Managed Schema".

    The correct procedure is:
    1. Log to Sitecore => go to Control Panel
    2. Click to "Populate Solr Managed Schema"
    3. Then click to "Deploy marketing definitions"
    4. Then click to "Indexing manager"
    5. And the last click to "Rebuild link databases"

    I think everything will be fine then.

    Best regards, Semrad Jiri
  • In reply to Jiri Semrad:


    Thank you for your reply - I was not able to log into Sitecore (the page was throwing an "Instance Failure" error), however I tried installing with SIF-less ( and that worked for me despite my doubts. Must have had a config setting wrong somewhere.

    Thanks again!
  • In reply to Naveed Ahmad:

    Hello! Thank you so much for your response - Solr was running fine, and I could not log into the site. It was throwing an "Instance Failure" error. See above comment for how I got this working.


  • In reply to Kayla Branch:

    I am glad you are able to solve this.
  • I also got this error, and for my case, it is due to double backslash in my Data Source connection string


        <add name="core" connectionString="Data Source=My-PC\\MSSQL2016;Initial Catalog=xp0_Core;User ID=coreuser;Password=Test12345" />
        <add name="master" connectionString="Data Source=My-PC\\MSSQL2016;Initial Catalog=xp0_Master;User ID=masteruser;Password=Test12345" />
        <add name="experienceforms" connectionString="Data Source=My-PC\\MSSQL2016;Initial Catalog=xp0_ExperienceForms;User ID=formsuser;Password=Test12345" />



    I used named instance in SqlServer as below

    $SqlServer = "My-PC\\MSSQL2016"


    After removing additional backslash in /App_Config/ConnectionString.config, I could run this last step to complete the installation.

    Supply -Tasks UpdateSolrSchema when running Install-SitecoreConfiguration again.

  • In reply to Arwin Lesmana Constantine:

    Hello All,

    I am pretty new to Sitecore and powershell.. I am trying to install sitecore9 on my local from one month.. i am running into errors and fixing them .Atlast i am struck with the following error. Please assist me ..

    [------------------------------------------------------------------------------------------------------------------- UpdateSolrSchema : SitecoreUrl ------------------------------------------------------------------------------------------------------------------------]
    VERBOSE: Resolving ConfigFunction extension 'concat'
    VERBOSE: Resolved 'Invoke-ConcatConfigFunction'
    VERBOSE: Invoke-ConcatConfigFunction
    VERBOSE: Concatenating: http:// sitecore9app.local
    VERBOSE: Result: http://sitecore9app.local
    VERBOSE: Performing the operation "Invoke-SitecoreUrlTask" on target "sitecore9app.local/.../PopulateManagedSchema.aspx
    [UpdateSolrSchema]:[Authenticating] sitecore9app.local/.../PopulateManagedSchema.aspx
    VERBOSE: GET sitecore9app.local/.../login with 0-byte payload
    >> TerminatingError(Invoke-WebRequest): "

    IIS 10.0 Detailed Error - 500.19 - Internal Server Error

    HTTP Error 500.19 - Internal Server Error
    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Detailed Error Information:

    Module&nbsp;&nbsp;&nbsp;IIS Web Core
    Handler&nbsp;&nbsp;&nbsp;Not yet determined
    Error Code&nbsp;&nbsp;&nbsp;0x80070021
    Config Error&nbsp;&nbsp;&nbsp;This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault=&quot;Deny&quot;), or set explicitly by a location tag with overrideMode=&quot;Deny&quot; or the legacy allowOverride=&quot;false&quot;.

    Config File&nbsp;&nbsp;&nbsp;\\?\C:\inetpub\wwwroot\sitecore9app.local\web.config

    Requested URL&nbsp;&nbsp;&nbsp;sitecore9app.local:80/.../login
    Physical Path&nbsp;&nbsp;&nbsp;C:\inetpub\wwwroot\sitecore9app.local\sitecore\login
    Logon Method&nbsp;&nbsp;&nbsp;Not yet determined
    Logon User&nbsp;&nbsp;&nbsp;Not yet determined

    Config Source:
    86: &lt;/modules&gt;
    87: &lt;handlers&gt;
    88: &lt;add name=&quot;WebDAVRoot&quot; path=&quot;*&quot; verb=&quot;OPTIONS,PROPFIND&quot; modules=&quot;IsapiModule&quot; scriptProcessor=&quot;%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll&quot; resourceType=&quot;Unspecified&quot; preCondition=&quot;classicMode,runtimeVersionv4.0,bitness32&quot; /&gt;

    More Information:
    This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.
    View more information &raquo;

    >> TerminatingError(Invoke-WebRequest): "

    IIS 10.0 Detailed Error - 500.19 - Internal Server Error

    Also, Do we need to run the whole installation script of Sitecore after fixing the error. please assist.

    Thanks in advance.
  • In reply to Kayla Branch:

    Hi Kayla,

    We ran into a similar issue and here is what resolved our issue.

    We got the same error as you are noticing, we could access SOLR, we could not login to sitecore.


    1. Go to Windows add/remove features and make sure the ASP, ASP.NET 3.5, ASP .NET 4.7 is checked as shown in the image below.

    2. We were able to login to sitecore and run "PopulateManagedSchema.aspx?indexes=all"

    Hope it helps.



  • Hi, It seems like the tasks to update the Solr schemas is failing.
    Please check 'Chris Auer' answer on the following page:
  • In reply to Anil Kumar Anagam:

    Looks like an issue with Sitecore Instance configuration.

    Are you able to open Sitecore admin login? If you can open it, go to Control Panel->Indexing->Populate Solr Managed Schema
  • We faced the similar error while installing Sitecore 9 Update 2, because I was configuring on the new machine with first time .Net/Sitecore installation. The problem was due to missing ASP component (ASP, 3.5 and 4.7)

    Go to > Control Panel\Programs\Programs and Features

    Click > Turn Window Features on or off

    Navigate To > Internet Information Services > World Wide Web Services > Application development features

    • ASP
    • net 3.5
    • net 4.7


    And make sure, all three above option should be checked, if not checked it and click ok.

    Hope, it will resolve the issue.

  • In reply to Harpreet Rana:

    Hi Harpreet,

    I was facing the same error. Even after trying this, there's no luck.
    I am not also able to log in to Sitecore in order to run the Indexing Manager.

    Is there any other solution to this?