Problem installing Sitecore 9

I'm trying to install Sitecore 9.

In the installation document it says to run this command: Register-PSRepository -Name SitecoreGallery -SourceLocation https://sitecore.myget.org/F/sc-powershell/api/v2

 

When I do, I get this response: Register-PSRepository : The specified Uri 'sitecore.myget.org/.../v2' for parameter
'SourceLocation' is an invalid Web Uri. Please ensure that it meets the Web Uri requirements.

 

This is on a Windows Sever 2016 Standard with PowerShell 5.1 

  • Have you tried to set the powershell execution policy to unrestricted. If not give it a try.

    -> set-executionpolicy unrestricted
    -> Register-PSRepository -Name SitecoreGallery -SourceLocation sitecore.myget.org/.../v2
  • Same problem here :( Any inputs?
  • Can you try this?

    $SitecoreModuleName = 'SitecoreInstallFramework'
    $SitecoreRepositoryUrl = 'https://sitecore.myget.org/F/sc-powershell/api/v2'
    $SitecoreRepositoryName = 'SCGallery'
    
    # Install NuGet package repository
    Install-PackageProvider "NuGet" -MinimumVersion 2.8 -Force | Out-Null
    
    # Install Sitecore's powershell gallery
    $SCGallery = Get-PSRepository $SitecoreRepositoryName -ErrorAction SilentlyContinue
    If ($null -eq $SCGallery) {
      Register-PSRepository $sitecoreRepositoryName $SitecoreRepositoryUrl -InstallationPolicy "Trusted" | Out-Null
    }
    
    # Install Sitecore Installation Framework
    $SIF = Get-Module $SitecoreModuleName -ListAvailable
    If ($null -eq $SIF) {
      Install-Module $SitecoreModuleName -Repository $SitecoreRepositoryName -Force | Out-Null
    }