I have sitecore packages more than 500 MB size. However, i am not able to upload this on sitecore 9.1.1 version.

I have sitecore packages more than 500 MB size. However, i am not able to upload this on sitecore 9.1.1 version. Kindly someone assist on this.

  • Generally, there are three places where you will need to modify settings for maximum file upload size (as has been pointed out in the blog post):

    <setting name="Media.MaxSizeInDatabase" value="500MB" /> in Sitecore's configurations
    <httpRuntime maxRequestLength="512000" ... in web.config (a child of the system.web configuration node)
    maxAllowedContentLength in request filtering settings if you are using IIS 7 or higher. You can either add this in web.config as the blog points out, or you can change this in IIS Manager (select the website, click on "Request Filtering", then on "Edit Feature Settings" in the side menu, and then change the value under "Maximum allowed content length (Bytes)").
    The fact that you are getting a negative value in the error message suggests that you might have incorrectly assumed the units when setting your values. Using the numbers above, 1] should be set in MB (including the "MB" after the value), 2] should be set in KB, and 3] should be set in bytes.

    Hope this helps.