Sitecore 9.3 XP-Single Azure Deployment with ARM Template

I need to deploy Sitecore XP-Single to Azure. In order to do that I used Azure Toolkit to create a package out of my local instance. I then uploaded the package along with Identitly Server and xp0xconnect packages that I downloaded from Sitecore Download center, to an azure blob storage. I, then, updated azuredeploy.parameters.json file accordingly, and ran the deployment command in powershell. However, I get the following error:

 

"Failed to
download package.\\r\\nAppGallery Deploy Failed: 'System.AggregateException: One or more errors occurred. --->
System.Net.WebException: The remote server returned an error: (404) Not Found.

 

 

New-AzureRmResourceGroupDeployment : 9:52:57 AM - Resource Microsoft.Resources/deployments
'deployment21042020-application-xc-as' failed with message '{
"status": "Failed",
"error": {
"code": "ResourceDeploymentFailure",
"message": "The resource operation completed with terminal provisioning state 'Failed'.",
"details": [
{
"code": "DeploymentFailed",
"message": "At least one resource deployment operation failed. Please list deployment operations for details.
Please see https://aka.ms/DeployOperations for usage details.",
"details": [
{
"code": "Conflict",
"message": "{\r\n \"status\": \"failed\",\r\n \"error\": {\r\n \"code\":
\"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state
'failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"Failed\",\r\n \"message\": \"Failed to
download package.\\r\\nAppGallery Deploy Failed: 'System.AggregateException: One or more errors occurred. --->
System.Net.WebException: The remote server returned an error: (404) Not Found.\\r\\n at
System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)\\r\\n at
System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)\\r\\n at
System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)\\r\\n --- End of inner exception stack trace
---\\r\\n at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)\\r\\n at
System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)\\r\\n at
System.Threading.Tasks.Task.Wait(TimeSpan timeout)\\r\\n at
Microsoft.Web.Deployment.WebApi.AppGalleryPackage.<Download>d__13.MoveNext()\\r\\n--- End of stack trace from
previous location where exception was thrown ---\\r\\n at
System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()\\r\\n at
System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\\r\\n at
Microsoft.Web.Deployment.WebApi.AppGalleryPackage.<Download>d__11.MoveNext()\\r\\n--- End of stack trace from
previous location where exception was thrown ---\\r\\n at
System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()\\r\\n at
System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\\r\\n at
Microsoft.Web.Deployment.WebApi.DeploymentController.<DownloadPackageAndSettings>d__25.MoveNext()\\r\\n--- End
of stack trace from previous location where exception was thrown ---\\r\\n at
System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()\\r\\n at
System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\\r\\n at
Microsoft.Web.Deployment.WebApi.DeploymentController.<DownloadAndDeployPackage>d__24.MoveNext()\\r\\n--->
(Inner Exception #0) System.Net.WebException: The remote server returned an error: (404) Not Found.\\r\\n at
System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)\\r\\n at
System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)\\r\\n at
System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)<---\\r\\n'\"\r\n }\r\n ]\r\n }\r\n}"
}
]
}
]
}
}'
At C:\Work\RD\DeployingSitecoreToAzure\AzureToolkit\SitecoreAzureToolkit\tools\Sitecore.Cloud.Cmdlets.psm1:115 char:35
+ ... eployment = New-AzureRmResourceGroupDeployment -Name $Name -ResourceG ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [New-AzureRmResourceGroupDeployment], Exception
+ FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.NewAzureResourceGroupDep
loymentCmdlet

New-AzureRmResourceGroupDeployment : 9:52:57 AM - At least one resource deployment operation failed. Please list
deployment operations for details. Please see aka.ms/DeployOperations for usage details.
At C:\Work\RD\DeployingSitecoreToAzure\AzureToolkit\SitecoreAzureToolkit\tools\Sitecore.Cloud.Cmdlets.psm1:115 char:35
+ ... eployment = New-AzureRmResourceGroupDeployment -Name $Name -ResourceG ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [New-AzureRmResourceGroupDeployment], Exception
+ FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.NewAzureResourceGroupDep
loymentCmdlet

New-AzureRmResourceGroupDeployment : 9:52:57 AM - Template output evaluation skipped: at least one resource deployment
operation failed. Please list deployment operations for details. Please see aka.ms/DeployOperations for usage
details.
At C:\Work\RD\DeployingSitecoreToAzure\AzureToolkit\SitecoreAzureToolkit\tools\Sitecore.Cloud.Cmdlets.psm1:115 char:35
+ ... eployment = New-AzureRmResourceGroupDeployment -Name $Name -ResourceG ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [New-AzureRmResourceGroupDeployment], Exception
+ FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.NewAzureResourceGroupDep
loymentCmdlet

New-AzureRmResourceGroupDeployment : 9:52:57 AM - Template output evaluation skipped: at least one resource deployment
operation failed. Please list deployment operations for details. Please see aka.ms/DeployOperations for usage
details.
At C:\Work\RD\DeployingSitecoreToAzure\AzureToolkit\SitecoreAzureToolkit\tools\Sitecore.Cloud.Cmdlets.psm1:115 char:35
+ ... eployment = New-AzureRmResourceGroupDeployment -Name $Name -ResourceG ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [New-AzureRmResourceGroupDeployment], Exception
+ FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.NewAzureResourceGroupDep
loymentCmdlet

 

 

I was thinking if you could help me fix this issue.