• Not Answered

Installation of Sitecore 9.3 on docker

Hi there,

I cloned a fresh docker image copy from github and followed the instructions to install/download the docker image but I am having issues. I get the following error when I try to run the Build.ps1 file

 Hash of 'Sitecore 9.3.0 rev. 003498 (WDP XM1 packages).zip' is invalid:
Expected: EA323F9145BABFDBE6D292D505430AEBAC6B7DA4D904B5BCF71ACBC037CDC4CA
Current : EF75C3BF43A71C2F47483762220C5A2D850C406182C5E26AFE2B6B27A301EF9D
The target file 'C:\sitecore9\docker-image\docker-images\windows\9.3.0\sitecore-assets\Sitecore 9.3.0 rev. 003498 (WDP XM1 packages).zip' was deleted, please also check the source file
'C:\sitecore9\docker-image\docker-images\packages\Sitecore 9.3.0 rev. 003498 (WDP XM1 packages).zip' and see if it is corrupted, if so delete it and try again.
At C:\sitecore9\docker-image\docker-images\modules\SitecoreImageBuilder\1.0.0\Public\Invoke-Build.ps1:191 char:29
+ ... throw ("Hash of '{0}' is invalid:`n Expected: {1}`n Curre ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OperationStopped: (Hash of 'Siteco... and try again.:String) [], RuntimeException
+ FullyQualifiedErrorId : Hash of 'Sitecore 9.3.0 rev. 003498 (WDP XM1 packages).zip' is invalid:
Expected: EA323F9145BABFDBE6D292D505430AEBAC6B7DA4D904B5BCF71ACBC037CDC4CA
Current : EF75C3BF43A71C2F47483762220C5A2D850C406182C5E26AFE2B6B27A301EF9D
The target file 'C:\sitecore9\docker-image\docker-images\windows\9.3.0\sitecore-assets\Sitecore 9.3.0 rev. 003498 (WDP XM1 packages).zip' was deleted, please also check the source file 'C:\sitecore9\docker-image\docker-images\packa
ges\Sitecore 9.3.0 rev. 003498 (WDP XM1 packages).zip' and see if it is corrupted, if so delete it and try again.

 

I have followed the instructions in the error and deleted the file and tried again. It downloads the file again but displays the same error.

I tried to download the file manually from dev.sitecore.net but I am prompted with a popup box which says: 

"Sorry – you do not have permission to download this file. If you are already Sitecore certified, please log in. If not, please visit the training section on sitecore.net to find out more about becoming Sitecore certified."

I am sitecore certified and completed my sitecore 9 certification in January. I can see this on my profile too.

So I am facing two issues:

Once is the docker error and other is the permission issue on sitecore website.

Does anyone know why I'm prompted with the permission message on dev.sitecore.net and who can I contact regarding this?