• Not Answered

Sitecore Xconnect MongoDB Provider Setup

I'm trying to setup mongoDB 4.0.5 analytics in Sitecore 9.3 instead of Default SQL analytics. As per Sitecore installation guide

To enable the MongoDB provider, Update the collection connection string to point to the MongoDB instance.

My questions is,  Do we need  point only collection to mongo DB as shown below or any other database need to point mongodb like xdb.processing.pools

 

<connectionStrings configBuilders="SitecoreConnectionStringsBuilder">
<add name="messaging" connectionString="user id=messaginguser;password=gs3O7bBAjNzCWpTlTygL;data source=SQLEXPRESS1;Initial Catalog=dev93_Messaging" />

<add name="processing.engine.storage" connectionString="user id=processingengineuser;password=Kbn2huw7hqPX2lriK2V5;data source=SQLEXPRESS1;Initial Catalog=dev93_ProcessingEngineStorage" />
<add name="reporting" connectionString="user id=reportinguser;password=Nwcr0YQPVUVNK086U1LL;data source=SQLEXPRESS1;Initial Catalog=dev93_Reporting" />

<add name="xdb.marketingautomation" connectionString="user id=marketingautomationuser;password=kp4OhrFE148OdVd8dkGg;data source=SQLEXPRESS1;Initial Catalog=dev93_MarketingAutomation" />

<add name="xdb.processing.pools" connectionString="user id=poolsuser;password=LyAN937qfDNhQOBjRmns;data source=SQLEXPRESS1;Initial Catalog=dev93_Processing.Pools" />

<add name="xdb.referencedata" connectionString="user id=referencedatauser;password=Q6nEWq7ATKJqb0FO6HpU;data source=SQLEXPRESS1;Initial Catalog=dev93_ReferenceData" />

<add name="collection" connectionString="mongodb://127.0.0.1:27017/dev93_collection" />

<add name="solrCore" connectionString="localhost:8983/.../dev93_xdb" />

</connectionStrings>

 

Appreciate any help on this