• Not Answered

X-Frame-Options errors in Content Editor after update to Sitecore 8.1 Update 3

Hi

After updating to 8.1 Update 3 I get a bunch of error message in the content editor

"X-Frame-Options may only be set via an HTTP header sent along with a document. It may not be set inside <meta>."

Any ideas where this comes from? I havent seen anything about adding custom headers to the web.config, some speak setting?

5 Replies

  • Apparently an official bug, answer from Sitecore support

    "A bug in the current version of Sitecore XP. To track the future status of this bug report, please use the reference number 120395. More information about public reference numbers can be found here.

    These <meta> tags were added to aspx pages in Sitecore Client by mistake. Browsers ignore the X-Frame-Options header if it is sent with the document and not in HTTP header. Please note that there is an HTTP module in web.config, which adds this header to requests. Therefore, you can safely ignore the errors in browser console."
  • In reply to Christian Raaschou:

    Hi,

    I have issue caused by Sitecore.Web.XFrameOptionsHeaderModule, when try to "Edit the related item" in Google Chrome, request is canceled and nothing change in UI.
    @Christian Raaschou: do you know the status of this bug fixing? I couldn't find the report.
  • In reply to Alexandr Tkachenko:

    I have installed Sitecore 8.2 and getting that same issue. Even though those errors can be safely ignored they fill up the Google Console pretty fast and is very annoying.
  • Any news about this yet? Sitecore 8.2-initial release has this issue as mentioned. It will crash Internet Explorer. I cannot find any information about this issue on the kb-site or on the sitecoresupport hub on github.
  • Christian Raaschou (ChristianRaaschou_378777353) - Do we've any updates on this? I can't find any fix for this. I checked on below two sites:

    Thank you,