Federated authentication in Sitecore 9.1 with Azure AD

Hi ,

We have configured federated authentication in SiteCore 9.1 by following the steps available at 

https://labs.techaspect.com/index.php/2018/02/16/integrating-federated-authentication-for-sitecore-9-with-azure-ad/

Now when we click on 'Sign-in with Azure Active Directory" on the login page its navigating to the O365 login page. Once we provide the valid credentials we are getting the below error in Sitecore.

 

"The requested document was not found "

Requested URL:/sitecore/identity/externallogincallback?returnurl=&sc_site=shell&authenticationsource=default

User Name:extranet\AnonymousSite

Name:website

 

Any help is much appreciated.

 

  • Hi ,

     


    Please chnage the following configuration in Azure AD and I am sure it will work.

    login url as "https://Sc.local.identityserver/signin-oidc" Prefix the Sitecore Identity server url with "signin-oidc"
    reply Url as "https://Sc.local.sc/Sitecore/login" in Azure AD App.

     

    Replace "Sc.local.identityserver"  with your identityserver host name.

    Replace "Sc.local.sc"  with your Sitecore host name.

     

    Identity Server prefix "signin-oidc" is missing in SItecore documentation.

     

    Please let em know if you have any query or issue.

     

    Br/

    Vikas

     

  • Hi Gokul,

    Try to replace the "replyUrls"  in Azure AD manifest file with

     
     
    Note : replace "sc910.identityserver" with your Sitecore Identity url
     
    regards,
    Rakesh