• Not Answered

Catalog Manager Crashes when opening view windows

When I open the SiteCore Commerce Catalog Manager no windows are displayed by default:




When I open the View tab and attempt to open open Catalog Sets, Inventory Catalogs, Search, or many other windows it crashes. No apparent error is logged on the server, but the following is logged in my local app log:

System.NullReferenceException: Object reference not set to an instance of an object.
   at CommerceServer.Core.UI.CatalogManager.CatalogManager.ReSetCurrentEditorColumns()
   at CommerceServer.Core.UI.CatalogManager.CatalogManager.ApplyColumnChanges(CatalogEditorType colType, Boolean loadListView)
   at CommerceServer.Core.UI.CatalogManager.CatalogManager.ChangeSearchColumnHeaders(Object sender, Object e)
   at CommerceServer.Core.UI.CatalogManager.CatalogManager.ToggleControlSetting(ToolBarButton btnToggleItem, Boolean toolBarButtonPushed, Boolean saveConfigration)
   at CommerceServer.Core.UI.CatalogManager.CatalogManager.tbMainButtonClicked(Object sender, ToolStripItemClickedEventArgs e)
   at System.Windows.Forms.ToolStrip.OnItemClicked(ToolStripItemClickedEventArgs e)
   at System.Windows.Forms.ToolStrip.HandleItemClick(ToolStripItem dismissingItem)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
   at CommerceServer.Core.UI.CatalogManager.LaunchPad..ctor()
   at CommerceServer.Core.UI.CatalogManager.LaunchPad.Main()

I've tried the following steps without any change:


1. I rebooted by local machine, and the server.
2. I verified that I have full admin permissions in the CatalogAuthorizationStore.
3. I cleared my local cache files in appData.
4. I'm able to rebuild and debug the catalog manager in Visual Studio without issues, but when I deploy it to my workstation the problem persists.

Also please note this isn't occurring for all users, and we've made no recent new development or configuration changes that are obviously related.

Does anyone have suggestions? Any assistance would be greatly appreciated.

Thanks,
William Davis

1 Reply