• Not Answered

Sitecore 9.2 installation error

Trying to install sitecore 9.2 and receiving the following error: 
 
 
Install-SitecoreConfiguration : Cannot validate argument on parameter 'Path'. The " Test-Path $_ -Type Leaf " validation 
script for the argument with value "C:\Projects\SC92\XP0-SingleDeveloper.json" did not return a result of True. Determine 
why the validation script failed, and then try the command again.
At C:\SC92\XP0-SingleDeveloper.ps1:74 char:31
+ Install-SitecoreConfiguration @singleDeveloperParams *>&1 | Tee-Objec ...
+                               ~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidData: (:) [Install-SitecoreConfiguration], ParameterBindingValidationException
    + FullyQualifiedErrorId : ParameterArgumentValidationError,Install-SitecoreConfiguration

3 Replies

  • I got similar error when my file path was wrong specially my config path was wrong so please check that the path to your config file is correct, and the file is there.

    Check $SCInstallRoot correct XP0-SingleDeveloper.ps1 in this file
  • In reply to Yogesh Sharma:

    That error is gone but receiving another error:

    --------------------------------- IdentityServer_InstallWDP : WebDeploy -------------------------------------------------]
    Install-SitecoreConfiguration : Cannot validate argument on parameter 'Path'. The running command stopped because the
    preference variable "ErrorActionPreference" or common parameter is set to Stop: The term 'C:\Program Files\iis\Microsoft
    Web Deploy V3\msdeploy.exe' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
    the spelling of the name, or if a path was included, verify that the path is correct and try again.
    At C:\Projects\SC92\XP0-SingleDeveloper.ps1:74 char:1
    + Install-SitecoreConfiguration @singleDeveloperParams *>&1 | Tee-Objec ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

    [TIME] 00:00:13
    Invoke-WebDeployTask : Cannot validate argument on parameter 'Path'. The running command stopped because the preference
    variable "ErrorActionPreference" or common parameter is set to Stop: The term 'C:\Program Files\iis\Microsoft Web Deploy
    V3\msdeploy.exe' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling
    of the name, or if a path was included, verify that the path is correct and try again.
    At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.1.0\Public\Install-SitecoreConfiguration.ps1:641
    char:25
    + & $entry.Task.Command @paramSet | Out-Default
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : InvalidData: (:) [Invoke-WebDeployTask], ParameterBindingValidationException
    + FullyQualifiedErrorId : ParameterArgumentValidationError,Invoke-WebDeployTask
  • In reply to SiteCore AtTor:

    The new error is about missing dependency WebDeploy3.6
    have you run the Prerequisites step successful?

    According to the error you miss this one:
    Check.WebDeploy3.6": "[GetPackage(Name:'Microsoft` Web` Deploy` 3.6',ErrorAction:'SilentlyContinue')]",

    You can also install it manually if you like, but you need all prerequisites for installing, so check else you probably run in another error when you fix this one. The "Installation Guide for the XM Scaled Topology" contain very detailed information about the prerequisites.
    for installing WebDeploy3.6 see:
    www.iis.net/.../web-deploy