Commerce setup issue profileEncryptionKeys issue

So im following the Commerce setup guide i have got this far http://commercesdn.sitecore.net/SitecoreCommerce/DeploymentGuide/en-us/index.html#Concepts/c_SC_SetUpCommerceServerSite.html

i have deployed the keys and have installed the profiles DB but when i load the site i get the error below

 

Any ideas?

 

Server Error in '/' Application.


Exception from HRESULT: 0xCA47800E

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Exception from HRESULT: 0xCA47800E

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[COMException (0xca47800e): Exception from HRESULT: 0xCA47800E]
   CommerceServer.Core.Interop.Profiles.ProfileServiceClass.Initialize(String sConfigStore, String sCatalog) +0
   CommerceServer.Core.Runtime.Profiles.ProfileContext..ctor(String profileServiceConnectionString, String providerConnectionString, String bdaoConnectionString, DebugContext debugContext) +809

[CommerceProfileSystemException: Failed to initialize profile service handle.]
   CommerceServer.Core.Runtime.Profiles.ProfileContext..ctor(String profileServiceConnectionString, String providerConnectionString, String bdaoConnectionString, DebugContext debugContext) +1386
   CommerceServer.Core.Runtime.CommerceContextFactory.CreateProfileContext() +939
   CommerceServer.Core.Runtime.CommerceContextFactory.get_ProfileContextSingleton() +119
   CommerceServer.Core.Runtime.Profiles.CommerceProfileModule.get_ModuleProfileContext() +138
   CommerceServer.Core.Runtime.Profiles.CommerceProfileModule.get_ProfileContext() +183
   Sitecore.Commerce.Connect.CommerceServer.Pipelines.CommerceProfileProcessor.Begin(CommerceProfileModule module) +26
   Sitecore.Commerce.Connect.CommerceServer.Pipelines.CommerceBaseModuleProcessor`1.BeginRequest(PipelineArgs args) +92
   Sitecore.Commerce.Connect.CommerceServer.Pipelines.CommerceBaseModuleProcessor`1.Init(PipelineArgs args) +176
   (Object , Object[] ) +74
   Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) +484
   Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain) +22
   Sitecore.Nexus.Web.HttpModule.Application_Start() +262
   Sitecore.Nexus.Web.HttpModule.Init(HttpApplication app) +704
   System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +618
   System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +172
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +402
   System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +343

[HttpException (0x80004005): Failed to initialize profile service handle.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +539
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +125
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +731
  • Hi Danny,

    check if your connection strings to the profile database are correct. Note that you have to check the connections in two places in Commerce Server Manager:
    The first one is on the profiles resource (Commerce Server Manager -> Global Resources -> Profiles)

    The other one is in the Data Sources (Commerce Server Manager -> Global Resources -> Profiles -> Profile Catalog -> Data Sources -> ProfileService_SQLSource)

    Best regards,
    Erwin
  • In reply to Erwin Werkman:

    Thanks for the info, so when i load up CSM i get the following error could not find stored procedure ' Sp_GetProfileCatalogs' could not load any catalogs.

    When i check the properties on the 3 connection strings and click modify then test connection they all work :/
  • In reply to Danny Wyatt:

    Are you using SQL or Windows authentication for the connection string to your profile DB? Is it possible the account being used does not have enough DB permission?
  • In reply to Hao Liu:

    I have tried both SQL and Windows auth its not made a difference unfortunately, i have checked the accounts in use have the correct access
  • In reply to Danny Wyatt:

    So can you check in SQL Management Studio to see do you actually have 'Sp_GetProfileCatalogs' as the error message complaining? How the profile resource and DB are created? You may need file a support ticket for deeper investigation.
  • In reply to Hao Liu:

    looks like Sp_GetProfileCatalogs is missing, not sure why
  • In reply to Danny Wyatt:

    Did you manage to solve the issue? I have exactly the same problem. The sp_getProfileCatalogs is also missing in the profiles table in my install.
  • In reply to Vadim Gusev:

    Assuming your profile resource/DB is created when executing the Initialize-CSSite command, did you get any error message when running this command?
  • In reply to Danny Wyatt:

    Try to create a new Commerce Server site. -->
    Apply the .dacpac from the installation guide on the new Profile database. -->
    Map the profile resource of the old site to the newly created Profile resource in CSM -->
    Right-click on a Profile Catalog item under the new Profile resource www.screencast.com/.../Vv2PgNUwQEl -->
    Import Profile Schema -->
    Use the file under Website\SitecoreCommerce\Data\Profiles -->
    Restart your IIS.