Document Upload using a non admin user

Sitecore 9.1

When uploading a document into the media library within a bucketed folder, it seems that the file is uploaded but user can't see the file; if the user tries to search for it, the results shows 1 for total results but an empty resulset. See screenshot 1 for a non admin user and Screenshot 2 for admin user.

Please help me figure this out. May be a permission needs to be set?

Thanks

Screenshot 1

Screenshot 2

  • Hi Oscar,

    For the non admin user are there multiple roles assigned? If yes then please check if any of these roles has explicit deny to the Media Library folders.

    If not and if you have created a custom role for this user then please grant that role read/write access explicitly for the parent of the bucketed folder under media library.

    You can check this under Role Manager. In the role manager click on the custom Role which you have created and then go to Security Editor.

    Let me know if this helps.
  • In reply to Rohan Kenkre:

    Hi Rohan,

    thanks for looking into this issue.

     

    The user has multiple roles assigned, non of the roles explicitly deny access to the Media Library folders.

    I have explicitly given access to the parent of the bucketed folder to Read, Write, Rename, Create, Delete, Administer, Inheritance. All possible options.

    If you have any other idea, please let me know.

    thanks again

    Oscar

  • In reply to Oscar Giraldo:

    Hi Oscar,

    Sorry for the late reply.

    Not able to re-produce this. I did try with normal folder and bucketed folder but it is working fine.. Issue occurs only when the user doesn't have read access to the folder/item.. Is there any customization in your instance, relevant to this.?

    Are you facing it on your local machine or all the environments?

    Thanks,
    Rohan
  • In reply to Rohan Kenkre:

    Hi Rohan,

    thanks for pointing me to the right direction. I have fixed the issue by giving the proper permission.

    Oscar
  • In reply to Oscar Giraldo:

    Hi Oscar,

    Good to know! And its my pleasure to help.

    Regards,
    Rohan