• Not Answered

New theme using the sxa cli not available to assign to a page design

For those living on the bleeding edge...

I have a fresh install of Sitecore 9.3 using SXA. So far so good, but after creating a custom theme using the SXA CLI the theme is not available for use with my Page Design.

I used this page as a guide https://doc.sitecore.com/developers/sxa/93/sitecore-experience-accelerator/en/add-a-theme-using-sxa-cli.html

In the set up I just used the default setting with the exception of the theme name and path. Also, the new theme appears in the Themes folder 

In '/sitecore/templates/Foundation/Experience Accelerator/Theming/_Page Design Theme' the source uses query:$compatibleThemes. I guess I would assume that a new theme created with the cli would be compatible by default. I also tried adding the Theme folder path to the source field and got the same result.

Sorry the details are a bit of a brain dump.

Anyone have any ideas what I missing?

Let me know if more detail is needed.

1 Reply