single site with multiple language version

Hi,

I have a single website in sitecore. I have added new language and content of that language. Now my single content have two versions(en, ar-QA). This website is developed using sitecore SXA. Now I have a dropdown in website to select language. When I select specific language from dropdown, it should show the content in selected language. Please suggest, how can I achieve this.

 

Thanks,

Ravi Sharma

  • In reply to Danny Paul van Iersel:

    Thanks for your reply Danny!

    It's not working in my case. I have done following settings in my application.

    Sitecore.Config:
    <site name="tns" IsSxaSite="true" enableTracking="true" virtualFolder="/" physicalFolder="/" rootPath="/sitecore/content/QNA/qna" startItem="/Home" database="web" domain="extranet" allowDebug="true" cacheHtml="true" htmlCacheSize="50MB" registryCacheSize="0" viewStateCacheSize="0" xslCacheSize="25MB" filteredItemsCacheSize="10MB" enablePreview="true" enableWebEdit="true" enableDebugger="true" disableClientData="false" cacheRenderingParameters="true" renderingParametersCacheSize="10MB"/>

    My website is working properly in english with http://localhost:8090. But when I open it with http://localhost:8090/ar-QA, it shows blank page with "Object moved to here." When I click on link it redirecs to other page with following information:

    Most likely causes:

    The resource you are looking for (or one of its dependencies) has been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    What you can try:

    Go back to the previous page
    Go to the start page


    Additional Information:
    Requested URL: /ar qa
    User Name: extranet\Anonymous
    Site Name: qna

    If the page you are trying to display exists, please check that an appropriate prefix has been added to the IgnoreUrlPrefixes setting in the web.config.

    Regards,
    Ravi Sharma