Sitecore Experience Analytics is not reporting correctly. - Sitecore 9.0.1

Hey guys,

Just posting here to see if anyone has seen this issue before.

I am running on sitecore 9.0.1 XP with scaling environment ( 4CDs + 1 CM). The reporting in Experience Analytics is not up-to-date and is about 1 month delayed. I have setup custom goals, and I can see them in _Xdb.Collection.Shard0/1 databases, and all interactions are up-to-date.  I have applied those amendments of sitecore configs for my CM server (i.e. this is also the server for reporting and processing) for config files as below:

1. Sitecore.Marketing.Operations.Xdb.ReferenceData.config

2. Sitecore.Marketing.Taxonomy.Xdb.ReferenceData.config

3. Sitecore.Xdb.Remote.Client.config

4. Sitecore.Xdb.Remote.Server.config

5. Sitecore.PathAnalyzer.RemoteClient.config

6. Sitecore.PathAnalyzer.Services.RemoteServer.config

 

I have also tried to rebuild reporting DB. The rebuild process was super slow and it was only processing about 70 items in 24 hrs. 

 

Do you know if there is any other setting I should apply to resolve this issuse? Thanks in advance

  • Hi

    I think this is because of certificate issue, Sitecore xconnect is run on https certificate , so these local self created certificate sometimes causing problem .

    In your power shell administrator mode try to run below command to check how many certificate are in trusted root folder .

    PS C:\WINDOWS\system32> Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject}

    Try to move them to CA

    PS C:\WINDOWS\system32> Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} | Move-
    Item -Destination Cert:\LocalMachine\CA

    Now clear cache and reload browser .
  • Please check whether below steps are performed during installation.

    • Install XConnect instance certificate into the CD servers
    • Right Click the certificate in personnel folder in MMC certificate manager and go to All task -> Manage Private Keys
      • Add the CD instance App Pool user to the security and provide Rights.
        • Note: You need to add like IIS APPPOOL\<AppPoolName>
    • Copy the certificate from personnel to Trusted Root Certification Folder in MMC Certificate manager.
    • Restart the CD instance & its App Pool once.

     

    Try now it should work without any xconnect SSL errors, if this is solved rest all will work smoothly.

  • Hi , I have faced the same issue when I set up my environment and I was getting an error message in the Log related to Device detection and Initially I was ignored it as I was not using this feature. Finally I have disabled it by setting Device detection false on Sitecore.CES.DeviceDetection.config and started working.