• Not Answered

Package install on Sitecore 8.2 hangs.

I'm trying to add Power Shell and SXA to the install, but it tries to transfer the file in 380B increments (from Firefox Console) and never gets above 1MB. The PowerShell package is relatively small but still the server only uploads in super small increments.

I'm using SQL server, SOLR 6.2.1 and a pretty basic install (prior to uploading the code base). I'm on Win10 and I'm not sure if it's the machine. Core i5, 32GB RAM.

7 Replies

  • Hi

    Please try to reset IIS using command prompt administrator mode first .

    It is recommended to install power shell module package in site core before installing SXA , please check whether you installed this before installation of SXA .

    If this not solved then try to remove all SXA config from C drive intepub -> sitecore9.0 folder-> App_config -> Include . Then try to install .

    Generally SXA failed installation or hang up when powershell module is not installed before install SXA .

  • workaround: place the packages in the "\Data\packages" folder and install without uploading.
  • In reply to Jan Bluemink:

    Thanks, will try that.
  • In reply to Jan Bluemink:

    Thanks for the suggestion. It didn't seem to work though. Now I'm seeing it on another machine a server 2016 install. Same behavior where the "hourglass" will just run and never complete.
  • In reply to Christian Howell:

    This is a huge blocker for me. I inherited some code bases and I need to get them worked on but they all require SPE and SXA and Unicorn. I can't get them to install even from the packages folder.
  • In reply to Christian Howell:

    Check the log file will installing the package there you can see the progress.
    Try it with clean config files. (remove everything and use only the original config files from Sitecore)
    If there are tools like synthesis, for example they can regenerate the model over and over again and slow done the installation.


    For the upload:

    1) Check the web.config on upload limits, httpRuntime maxRequestLength and the <security>
    <requestFiltering>
    <requestLimits maxAllowedContentLength=

    2) Check the <processors>
    <uiUpload> in the config (you can do it with the url /sitecore/admin/showconfig.aspx on CM, are there custom processors?

    3) check the log maybe there is somethings that explain.
  • In reply to Jan Bluemink:

    I am starting from a fresh install with the SIM v1.5 and v8.2 SOLR search. I checked all the areas you suggested and the values seem large enough. There are no custom processors. The problem it seems is that it's not throwing an error just freezing on 1000s of small GET requests.