Sitecore upgrade from 8.0 to 8.1, facing error.

I have upgraded  sitecore from 8.0 to 8.1.

Now i am facing following error, please help me on this:

 

 

Could not resolve type name: Sitecore.Pipelines.RenderField.GetIntegerFieldValue,
Sitecore.Kernel (method: Sitecore.Configuration.Factory.CreateType(XmlNode configNode, String[] parameters, Boolean assert)).

 

 

[Exception: Could not resolve type name: Sitecore.Pipelines.RenderField.GetIntegerFieldValue,
Sitecore.Kernel (method: Sitecore.Configuration.Factory.CreateType(XmlNode configNode, String[] parameters, Boolean assert)).]
Sitecore.Diagnostics.Error.Raise(String error, String method) +129
Sitecore.Configuration.Factory.CreateType(XmlNode configNode, String[] parameters, Boolean assert) +428
Sitecore.Configuration.Factory.CreateFromTypeName(XmlNode configNode, String[] parameters, Boolean assert) +67
Sitecore.Configuration.Factory.CreateObject(XmlNode configNode, String[] parameters, Boolean assert, IFactoryHelper helper) +141
Sitecore.Pipelines.CorePipelineFactory.GetObjectFromType(String type, XmlNode processorNode) +144
Sitecore.Pipelines.CoreProcessor.GetMethod(Object[] parameters) +124
Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) +431
Sitecore.Web.UI.WebControls.FieldRenderer.RenderField() +631
Sitecore.Form.Web.UI.Controls.FieldRenderer.Render(Item item, String field, String parameters, Boolean webEditDisabled) +346
Sitecore.Form.Web.UI.Controls.FieldReference.get_InnerControl() +325
Sitecore.Form.Web.UI.Controls.FieldReference.get_IsHasTitle() +16
Sitecore.Form.Web.UI.Controls.ControlReference.get_Reference() +174
Sitecore.Form.Web.UI.Controls.ControlReference.OnInit(EventArgs e) +17
System.Web.UI.Control.InitRecursive(Control namingContainer) +186
System.Web.UI.Control.AddedControl(Control control, Int32 index) +189
Sitecore.Form.Web.UI.Controls.FormSection.AddFields(Control content) +366
Sitecore.Form.Web.UI.Controls.FormSection.OnInit(EventArgs e) +1040
System.Web.UI.Control.InitRecursive(Control namingContainer) +186
System.Web.UI.Control.AddedControl(Control control, Int32 index) +189
Sitecore.Form.Web.UI.Controls.SitecoreSimpleFormAscx.OnInit(EventArgs e) +948
System.Web.UI.Control.InitRecursive(Control namingContainer) +186
System.Web.UI.Control.AddedControl(Control control, Int32 index) +189
Sitecore.Form.Core.Renderings.FormRender.OnInit(EventArgs e) +841
System.Web.UI.Control.InitRecursive(Control namingContainer) +186
System.Web.UI.Control.InitRecursive(Control namingContainer) +291
System.Web.UI.Control.InitRecursive(Control namingContainer) +291
System.Web.UI.Control.InitRecursive(Control namingContainer) +291
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2098

  • Hi Jaideep,

    Can you please check your upgraded solution Sitecore.Kernel.dll version with the Sitecore 8.1 version dll? If version is still referencing old one then replace both Kernel and client with the latest Sitecore version dll's and check.
  • In reply to Yogeshwer Sharma:

    I had the error described in this original post. My 8.0 to 8.1 (initial release on both) did not go very well, so I attempted to apply 8.1 to U1 to the result. That didn't work either. Reverted everything and went the long way of stepping through each 8.0 update through 7 successfully, then updated that to 8.1 initial release and was getting "unable to resolve RenderField.GetIntegerFieldValue" from Sitecore.Kernel.
    GetIntegerFieldValue is not available until 8.1U1 (it's even added in the 8.1U1 config notes) .. so once I applied the 8.1U1 update, it cleared the error.