Sitecore 9 Install Solr Errors

Still trying to install Sitecore 9 for an eLearning training class....

I tried installing Solr 6.6.2 and 6.6.3, but neither will run as a service.  I get the following error:

Solr 7.3.0 runs fine, but the folder structure has changed which screws up the install.  

I changed the BasicConfig parameter in sitecore-solr.json and xconnect-solor.json to the following, but it didn't help.

"BaseConfig": {
"Type": "string",
"DefaultValue": "_default\\conf",
"Description": "The configset to copy as a base for each core."
},

 This is the error in the xconnect.xp0 log file:

Install-SitecoreConfiguration : Service 'Sitecore XConnect Search Indexer - tac.xconnect-IndexWorker
(tac.xconnect-IndexWorker)' stop failed.
At C:\repos\SitecoreConfigInstall\SIFless-EZ-1528822433.ps1:42 char:1
+ Install-SitecoreConfiguration @xconnectParams
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration
Install-SitecoreConfiguration : Service 'Sitecore XConnect Search Indexer - tac.xconnect-IndexWorker
(tac.xconnect-IndexWorker)' stop failed.

 

Any suggestions, ideas, moral support greatly appreciated!

  • Can you start Solr 6.6.x from command line without windows services:

    cd C:\solr-6.6.2\bin
    solr start -p 8984

    If the issue is JAVA.
    Adjust the JAVA path as needed in the SOLR install script note: use Java 8. Solr 6.6 is not working with Java 9

    And set your JAVA_HOME environment variable: somethings like
    JAVA_HOME=C:\Program Files\Java\jre1.8.0_161
    and after updating JAVA usual SOLR is not starting up, you need to adjust the path manually.