Why isn't this Email Action in a publishing workflow working?

I'm trying to add an Email Action to a publishing workflow to email a content approver when someone submits content to be approved. It's supposedly a very simple thing to do, according to http://www.tanasuk.com/blog/Sitecore%20Workflow%20Emails%20Notifications but nothing I've tried so far has worked.

I've tried putting the action in different places, but usually, it ends up breaking the author's ability to submit items. I have the to:, from:, subject, message, and mail server settings all entered. This is how I have it at the moment, but it still isn't sending an email.

For starters, is my placement totally wrong?

  • I did this work many years ago on email actions in Sitecore. This might give you some bells and whistles you're looking for.

    Having looked at that post, I think your action should be directly under "submit" item.  I've linked to an image below.

  • First, thanks for responding, Dan, and that custom email action looks great! So far I can't get the "built-in" action to send an email at all, though, and I'm having trouble determining if it's a simple configuration issue, or if there is a larger problem. We have no trouble getting emails to send from WFFM, but so far, nothing has ever worked with our workflows.

    I did try moving the action as you suggested, but it caused a situation where an author could click Submit on their side, but nothing would happen and the item wouldn't move forward to the next state.

    I'm wondering now if it's a configuration issue somewhere, perhaps with the mail server. If I ever sort it out, I'll be back over to check out your module as a possible upgrade!
  • In reply to Michael Tucker:

    For the benefit of and anyone else who stumbles across this, my issue ended up being that the default Email Action in Sitecore apparently does not support sending emails through an email server that uses a username and password, which ours does. A custom email action had been created for our site, I just didn't know to use that one instead of the default one.