• Not Answered

Sitecore 9 Experience Analytics showing empty results.

Hello I guys, 

I have installed fresh instance of sitecore 9 xp1 on production, but unable to see data under experience analytics dashboard. however I am able to see visits if check "Acquisition" tab

I am getting following error in xcollection logs

 

2019-02-14 14:02:30.794 +05:00 [Information] Create "XdbContextLoggingPlugin"
2019-02-14 14:02:30.841 +05:00 [Information] Register "XdbContextLoggingPlugin"
2019-02-14 14:02:31.779 +05:00 [Error] Sitecore.XConnect.Operations.XdbSearchOperation`1[Sitecore.XConnect.Contact]: System.NotSupportedException: Specified method is not supported.
at Sitecore.Xdb.Collection.Indexing.IndexReaderDisabled.SearchContacts(SearchQuery searchQuery)
at Sitecore.Xdb.Collection.Repository.<SearchContacts>d__11.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Sitecore.Xdb.Collection.RepositoryCountersDecorator.<SearchContacts>d__8.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Sitecore.XConnect.Service.RepositorySearchInvoker.<Execute>d__7.MoveNext()

 

1 Reply

  • Hi

    Please check if xconnect is running on https certificate properly , these local self created certificate sometimes causing problem .

    In your power shell administrator mode try to run below command to check how many certificate are in trusted root folder .

    PS C:\WINDOWS\system32> Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject}

    Try to move them to CA

    PS C:\WINDOWS\system32> Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} | Move-
    Item -Destination Cert:\LocalMachine\CA

    Now clear cache and reload browser