• Not Answered

Sitecore 8.2 Page test | Content tree is empty on the "select page to test" window

Hi guys,

 

I have a strange bug on UAT and Production.

 

When trying to create a page test, the content item doesn't have any children/subitems on the "select page to test" window. On my local/dev site it shows fine but doesn't show on UAT and Production. 

 

I have tried rebuilding my index but that doesn't help at all. I don't get anything from the log files.

Please help.

Regards,

Dakalo

4 Replies

  • Do you have any js errors in the browser?
  • Please share logs as well, if environment is load balanced share from all servers
  • In reply to Marek Musielak:

    Hi Marek,

    This is the only JavaScript console error:
    <!--
    [HttpException]: A public action method &#39;SetUserProfileKey&#39; was not found on controller &#39;Sitecore.Controllers.SettingsController&#39;.
    at System.Web.Mvc.Controller.HandleUnknownAction(String actionName)
    at System.Web.Mvc.Controller.<BeginExecuteCore>b__1d(IAsyncResult asyncResult, ExecuteCoreState innerState)
    at System.Web.Mvc.Async.AsyncResultWrapper.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult)
    at System.Web.Mvc.Controller.EndExecuteCore(IAsyncResult asyncResult)
    at System.Web.Mvc.Async.AsyncResultWrapper.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult)
    at System.Web.Mvc.Controller.EndExecute(IAsyncResult asyncResult)
    at System.Web.Mvc.MvcHandler.<BeginProcessRequest>b__5(IAsyncResult asyncResult, ProcessRequestState innerState)
    at System.Web.Mvc.Async.AsyncResultWrapper.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult)
    at System.Web.Mvc.MvcHandler.EndProcessRequest(IAsyncResult asyncResult)
    at Sitecore.Mvc.Routing.RouteHttpHandler.EndProcessRequest(IAsyncResult result)
    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    --><!--

    That error also appears on my dev instance although the dev instance doesn't have the same problem.
  • In reply to Sachin Magon:

    Hi Sachin,

    There's only one cm server and 2 cd servers, I can't find anything relevant in the log files.

    Thanks