• Not Answered

Creating new version of an item issue

Hi! Good day! I have a problem when creating a new version of item it goes back to its standard values when in it is supposed to get the values of the current version of that particular item. What might be the reason for this issue? Is this a sitecore bug? Thanks :)

6 Replies

  • Which Sitecore version are you using?

    Do you make the version in exactly the same language as the version you expect the values to be?
    How do you create the version? Do you use a workflow to create a new version?. is it working well when u use the Add button in the versions topbar-tab?


    Are there any custom events in the config, in events like <event name="item:versionAdding"> or <event name="item:saving"> (a admin can see the config with /sitecore/admin/showconfig.aspx on CM server)
  • In reply to Jan Bluemink:

    Hi! Thank for your reply.

    I'm using Sitecore 8.2


    Yes, it's exactly the same language as the version I am expecting. I've created the version by clicking the "Version" tab and then "Add" and yes it's working well.

    The events (<event name="item:versionAdding"> and <event name="item:saving">) that you've mentioned are both in the custom events. Is this the reason why?
    I just wanted to know the root cause of this issue. Thank you.
  • In reply to Rizza Caballe:

    Rizza,
    So is it working via "Add" button? Are you adding new version pragmatically and it is not copying values over then? I believe you would have to copy values in your code after creating new version via Versions.AddNew()
  • In reply to Alex Kronberg:

    I've just added it in Content Editor. I'm just wondering why it did not copied the values from the previous version and go back to its standard values instead so we can prevent this kind of issue in the future. :)
  • In reply to Rizza Caballe:

    I think that by default Sitecore does not perform copy of old values. You can either copy from another language copy (there is a button for that), or use Add Version and Copy module from marketplace for deep copy of top item and child items as well.
  • In reply to Alex Kronberg:

    Hi. Surely when a new version is created the standard values will remain. Have you tried unchecking the Standard Values checkbox in the nav?