How to enable full configuration in rich text editor

Hi,

 

When I open the Rich text editor, I only see the basic functionality. How do I enable the full configuration as shown here https://codebuildplay.wordpress.com/2014/11/21/how-to-setup-the-rich-text-editor-in-sitecore-the-basics/.

 

Regards,

Ronald

  • Hi Ronald,

    you need to reference the full editor profile in the Source field of the Rich text field. Here are the paths of the predefined editor profiles of Sitecore 8.1 (note that these are in the core database):

    • /sitecore/system/Settings/Html Editor Profiles/Rich Text Default
    • /sitecore/system/Settings/Html Editor Profiles/Rich Text Full
    • /sitecore/system/Settings/Html Editor Profiles/Rich Text IDE
    • /sitecore/system/Settings/Html Editor Profiles/Rich Text Medium

    To get the full-fledged rich text editor, use /sitecore/system/Settings/Html Editor Profiles/Rich Text Full:

     

    If you know which editor profile you will use most, you can also change the config setting HtmlEditor.DefaultProfile. That way a rich text field with an empty source will default to the configured editor profile.

     

    Greetz,
    Markus

     

    EDIT 1:

    • Added the paths of all rich text editor profiles for reference
    • Added description of HtmlEditor.DefaultProfile
  • Hi Ronald,

     

    The rich text  is set to Default Rich Text by default. You can choose to make it Rich Text Full, Rich Text Medium. Check here for the steps: http://blog.arkesystems.com/post/2010/10/13/Sitecore-Setting-and-Customizing-the-Rich-Text-Field-Editor.aspx.

     

    Regards,

    Amrita

  • In reply to Markus Klimmasch:

    Hi,

    Thanks for all you responses.

    I am following the steps at the following link www.markstiles.net/.../.

    But even though I am logged in as a admin, I am unable to see the folder HTML Editor Profiles under settings.

    I have in the View tab Hidden Items checked and Full Content Tree is also checked.

    Regards,
    Ronald
  • In reply to Ronald Mathias:

    Hi Ronald,

    this is not working the described way because the profiles are in the Core database. Just copy the path from my previous answer and it shoud work (for Sitecore 8.1 update 3).

    If you want the paths of the other profiles, the easiest way IMO is to manually change the DB to core (through the Desktop), find the items in the content editor and copy their paths from the Quick Info section (which you might have to activate first).

    Greetz,
    markus
  • In reply to Markus Klimmasch:

    Hi Markus,

    Thanks. I have followed your suggestion and its working. Thanks again for taking time to answer.

    Regards,
    Ronald
  • In reply to Markus Klimmasch:

    I would also notice that a common practice is to go into Core database and DUPLICATE the Full editor profile and customize it as needed (remove, add, etc). You can have multiple ones - one as a default and specific ones as needed. In order to point your Rich Text field to appropriate profile, populate "datasource" of the Rich Text field with a path to desired editor profile.
  • In reply to Markus Klimmasch:

    Good morning,
    I've followed this suggestion and I was able to enable Full Ribbon in my Rich Text Field.

    Question: is the rich text full profile able to manage LINE SPACING?

    Thanks, regards
    Simone