Rebuilding Reporting Index taking long time and not succeeding

Hi Team,

I tried rebuilding the reporting index twice but it did not succeed anytime. This process takes long time, in my case I started over weekends (Friday) and continued till (Tuesday morning IST) around 3 Days. The status displays as "Processing History". This status came up on 1st day of rebuilding (i.e. Friday) itself and was same till Tuesday morning. Finally, I killed the process.

When I went to log, it says below error.

5852 2019-02-16 07:23:36 INFO ************************************************** 5852 2019-02-16 07:23:36 WARN Sitecore shutting down 5852 2019-02-16 07:23:36 WARN Shutdown message: HostingEnvironment initiated shutdown 6104 2019-02-16 07:23:36 ERROR Evaluation of condition failed. Rule item ID: Unknown, condition item ID: Unknown Exception: System.Threading.ThreadAbortException Message: Thread was being aborted. Source: MongoDB.Driver.Core at MongoDB.Driver.Core.Connections.BinaryConnection.ReceiveBuffer() at MongoDB.Driver.Core.Connections.BinaryConnection.ReceiveBuffer(Int32 responseTo, CancellationToken cancellationToken) at MongoDB.Driver.Core.Connections.BinaryConnection.ReceiveMessage(Int32 responseTo, IMessageEncoderSelector encoderSelector, MessageEncoderSettings messageEncoderSettings, CancellationToken cancellationToken) at MongoDB.Driver.Core.ConnectionPools.ExclusiveConnectionPool.AcquiredConnection.ReceiveMessage(Int32 responseTo, IMessageEncoderSelector encoderSelector, MessageEncoderSettings messageEncoderSettings, CancellationToken cancellationToken) at MongoDB.Driver.Core.WireProtocol.CommandWireProtocol`1.Execute(IConnection connection, CancellationToken cancellationToken) at MongoDB.Driver.Core.Servers.Server.ServerChannel.ExecuteProtocol[TResult](IWireProtocol`1 protocol, CancellationToken cancellationToken) at MongoDB.Driver.Core.Servers.Server.ServerChannel.Command[TResult](DatabaseNamespace databaseNamespace, BsonDocument command, IElementNameValidator commandValidator, Func`1 responseHandling, Boolean slaveOk, IBsonSerializer`1 resultSerializer, MessageEncoderSettings messageEncoderSettings, CancellationToken cancellationToken) at MongoDB.Driver.Core.Operations.CommandOperationBase`1.ExecuteProtocol(IChannelHandle channel, ServerDescription serverDescription, ReadPreference readPreference, CancellationToken cancellationToken) at MongoDB.Driver.Core.Operations.CommandOperationBase`1.ExecuteProtocol(IChannelSource channelSource, ReadPreference readPreference, CancellationToken cancellationToken) at MongoDB.Driver.Core.Operations.ReadCommandOperation`1.Execute(IReadBinding binding, CancellationToken cancellationToken) at MongoDB.Driver.Core.Operations.FindCommandOperation`1.Execute(IReadBinding binding, CancellationToken cancellationToken) at MongoDB.Driver.Core.Operations.FindOperation`1.Execute(IReadBinding binding, CancellationToken cancellationToken) at MongoDB.Driver.MongoCursor`1.GetEnumerator() at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection) at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source) at Sitecore.Analytics.Outcome.Data.MongoDbOutcomeRepository.GetForInteraction(ID entityId, ID[] interactionIds) at Sitecore.Analytics.Outcome.OutcomeManager.GetForInteraction[T](ID entityId, ID[] interactionIds) at Sitecore.PathAnalyzer.Rules.Conditions.OutcomeMapCondition`1.Execute(T ruleContext) at Sitecore.Rules.Conditions.WhenCondition`1.Evaluate(T ruleContext, RuleStack stack) at Sitecore.Rules.RuleList`1.Run(T ruleContext, Boolean stopOnFirstMatching, Int32& executedRulesCount)

 

Could anyone please let me know what went wrong?

Thanks,

Mani